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Instruction Manual

No. M2380YS-03

Publication History
Edition Date of Issue
First Edition July 27, 2004
Second Edition April 13, 2009

Third Edition June 11, 2009

Note

Description
- Initial Publication

- Fully revised due to adding features

- Messages are added at the section on Saving a File.

- The order of sections, Saving a File and Modifying a
File, is changed.
- Error messages are added to the Appendix.

- The description of upper limit of the Size is changed.

(1) No part of this manual may be reproduced or transmitted in any form or by any means,
electronic or mechanical, without the written permission of DTS INSIGHT CORPORATION.
(2) The contents of this manual are subject to change without prior notice due to improvement of

the functionality.

(3) If any question about the contents of this manual arises, contact DTS INSIGHT

CORPORATION.

(4) DTS INSIGHT CORPORATION shall not be held responsible for direct or indirect adverse
effects resulting from operation of this system irrespective of the above item (3).

© 2009 DTS INSIGHT CORPORATION. All rights reserved.

Printed in Japan
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1 Overview and Features

This program is software to generate a KEY file on a Windows PC (PC/AT).
With this program, the KEY file can be laid out freely to suit your system and generated efficiently.
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2 Before Use

2-1 System Requirements for KEY File Generator

PC

IBM PC/AT compatible machine Windows 2000, XP,~Vista

<Note>

1. This product has no feature to connect with the programmer main unit.
2. Installation of this product requires Administrator privileges.
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3 Generating a File

This product has the feature which enables the user to freely design the layout of the KEY file

varying with the target system.
In this instruction manual, the designed layout information file is called "Template file".
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3-1 Setting Sort and Address duplication check when Saving a File

Setting sort (addresses in ascending) and address duplication check are to be ON/OFF when
saving a KEY file and a template file.

The sort (address in ascending) function is to sort data by the address in ascending order when
saving a file.

The address duplication check function is to check whether there are two or more data located on
the same address or not.

Choose [Address Sort On] or [Address Sort Off] from the Option menu.

JAKEY File Generator

FilelE) AddressSize(f) | Option(0)  Help(H)
« fddrezs Sort On()
Addresz Sort OFH(E)
KEY File Generator
File: |
Mo. | Address | Size Type Data Title
| 00 01 02 03 04 05 0§ 07 08 03 0A OB 0C 0D OE OF
I 1 HEX j ill
I 2 HEX j
I i HEX j
I 4 HEX j
I 5 HEX j
I 6 HEX j
I 7 HEX j
I 8 HEX j
I 9 HEX j
I 10 HEX j =
Bl B
I
Address Sort On Sort (addresses in ascending) and address duplication check are
executed.
Address Sort Off Sort (addresses in ascending) and address duplication check are
NOT executed.
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When Address Sort Off is chosen, the message “Address Sort Off” is displayed at the lower left of

the window.

R KEY File Generator

File(E) AddressSize(f) | Option(Q) Help(H)
fddress Sort OniN)

« A

Y File Generator

File: |
Iﬁ Address | Size | Type Data Title
00 01 02 03 04 05 06 07 08 0% 0A OB 0C 0D OE OF

Il_ HEX j ill
lT HEX j
IT HEX j
IT HEX j
IT HEX j
lT HEX j
lT HEX j
IT HEX j
[o] | fmx |
o] | fmex 2 | =

Address Sort Off 4] ]
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3-2 Generating a File
The address size is to be specified.
In default configuration, the address length of output file is 32 bit.

In order to change the address length to output, specify among 16 bit or 24 bit or 32 bit from the
Address Size menu.

KEY File Generator

File: |

Iﬁ Address | Bize | Type Data Title
00 01 02 03 04 05 06 07 08 0% 04 OB OC 0D 0E OF

|1_ HEX 7] ﬁ!
IT HEX j
IT HEX j
|T HEX 7]
|T HEX 7]
IT HEX j
IT HEX j
|T HEX 7|
IT HEX j
10 HEX |~
i N ] .

<Note>

If the address length is specified shorter than current, the address length is shortened a few bytes as
well.

As a result, a few bytes of the upper address are to be discarded.
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Items to be specified
The data length is specified in the Size column. The upper limit of the data length is 252.
The data input type is specified in the Type column in advance of data input.

(Cannot be changed after data input)
Data can be input in hexadecimal by specifying HEX, and in ASCII text by specifying ASCII.
The KEY data is input in the Data area.
When the Type is specified HEX, the Data input area will be divided to 16 per line. In each divided
area,1 hexadecimal byte (2 digits) can be input. With horizontal scroll bar, the Data input area can be

scroll displayed.

When the Type is specified ASCII, the Data input area can be input with text.

JB KEY File Generator [Modified]
File(F) AddressSizelfy) Option{Q) Help(H)
KEY File Generator
File: |

Iﬁ Address | Size | Tipe Data Title

00 01 02 03 04 05 06 07 08 0% 0A OB OC 0D OE OF
[Tfeozooo o fuex F[ [ T T T T DT T T T T LT T T Jlees -
ITloozozo |1D IASCII = Ida‘tE
IT HEX j
IT HEX j
IT HEX j
IT HEX j
IT HEX j
IT HEX j
IT HEX j
IT HEX j =

1 5 =
|

Select [File Save] from the File menu to save the data after modifying.

<Note>

1. The upper limit of the number of the data line is 256.

2. Data more than the specified length in the “Size” column can not be input in the Data area.
(Except the data length is specified 0 in the “Size” column.)

3. The maximum number of data which can be input in one line of the Data area varies with the
specified address length in the AddressSize menu.

AddressSize Max. number of data
16hit 252
24bit 251
32bit 250
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3-3 Saving a File

After the items are specified, the file is to be saved.
Select [File Save] from the File menu.

n KEY File Generator [Modified]

FilelF) AddressSize(fd  Option{D)  HelplH)

el M)

i KEY File Generator

Extract KEY DatalE]..

Endiz) File: |

Mo. | Address | Size Type Data Title

|_ |00 01 02 05 04 05 06 07 08 0% 0A OB OC 0D OE OF |

Il_ oozooo  |[30 |pEx j user ﬂ

IT oozozo |10 |mEx j date

IT ooisoo  |s HEX 7] user_1Dh

0

IT HEE j

IT HEE j

IT HEZ j

=] EEE |

IT HEE j

IT EEX 7| -
i 3 =
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The dialog shown below will appear.
Select the file type, enter the file name and save.

savens x|

Save jr: | () KEY File - «e®mceEm-

[ TEST24K KEY !

iy Documents

.

ty Computer

Save

[
Cancel |
e

File narme: I j
i

Save az lype: IKEY File(* KEY)

<Note>

1. Blank lines will be deleted automatically when saving a file.

2. By setting the data length O in the Size column, the actual length of the data input will be
displayed in the Size column when saving the file.

3. Ifthere is any line with no address specified, the message as shown below will appear and the
file can not be saved successfully. Specify an address to the line and retry to save.

Mo Address.
LineMao: 1

4. Ifthereis any character other than hex in the Data column when the Type of the line is specified
HEX, the message shown below will appear and the file can not be saved successfully. Correct
the data and retry to save.

B ERROR

lllegal HEX Data.
LineMao: 1
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By setting the Address Sort function ON, the data are sorted by the address in ascending order

5.
and checked if there are two or more data located on the same address or not..
If there is any address duplication found, the message shown below will appear and the file can
not be saved successfully. Correct the address and retry to save.
<Example>
B ERROR
° Duplicated Address
Mo2 Hod
Save the file after correcting the duplicated Address
This example message tells that the data on the line No.3 and line No. 4 have
the same address.

6. If the sum of the address size, the data length, and the check sum (1 byte) is exceeded the
number of the record per line of S-record (255 bytes), the warning message as shown below
will appear.

Click OK to adjust the data size automatically (The exceeded data will be discarded.)
Click Cancel to cancel saving the file.
W WARNING x|
The size of Srecord is exceeded,
! LimeMo: 1
Conkinue 7
Cancel |
7. If less data than the specified data length in the Size column are input in the Data area, the

warning message as shown below will appear after entering the file name to save.
Click OK to enter “FF" automatically to fill the lack of data.
Click Cancel to cancel saving the file.

M WARNING x|
The size of data is different.
! LimeMo: 1
Continue ¥

Cancel |
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3-4 Modifying a File

Go to [File Open] from the File menu.

A KEY File Generator

FilefF) ~AddressSize(d) Option(Q) Help(H)

New(M)
KEY File Generator
Extract KEY Data(E}..
End(x0 File: |
Iﬁ Address | Size | Type Data Title
00 01 02 03 04 05 06 07 08 09 0A OB 0C 0D O OF
s wz =
IT HEX j
IT HEX j
IT HEX j
IT HEX j
0
IT HEX j
IT HEX j
IT HEX j
10 HEZ -
[10] [ Jﬂ j| -

The message as shown below will appear when the data are being modified.
Click Yes to save the modified data.

Click No to discard the modified data.

To cancel the operation, click Cancel.

Il Destroy this data x|

! 3 This data is modified.

Do wou wank ko save the changes?

o Cancel
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Specify the file type and select a file to open, and click Open.

Lok jre | () KE' File - « @k E

[ TEST24K KEY:

ty Cornputer

File name: I j Open I
Filez of type: IKEY File[* K.E] j Cancel |
g

Each column and area will be loaded with corresponding data and able to be modified.

R KEY File Generator [Modified]

File(F) AddressSize(d) Option(0) Help(H)

KEY File Generator

File: |
|ﬁ Address | Size | Tipe Data Title
00 01 02 03 04 05 06 07 08 0% 0A OB OC 0D OE OF
ll_ oozooo |30 |mEx j user ﬁl
IT 00zozo  [10  |mEx j date
IT ooisoo s HEX  v) user_ID
IT HEX  v]
IT HEX  ¥]
IT HEX 7|
IT HEX  v)
L |
IT HEX  v]
IT HEX  v] -
K 5 =
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DTS INSIGHT CORPORATION




<Note>
1. The file which can be loaded is the Template file or S format. When a file other than these file
types is selected to load, the error message as shown below will appear and file loading is not
to be done.
<Example>

B ERROR

. llegal file loading.
Select the appropriate file

- I©
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3-5 Data Extraction

To extract the data to be the key from the object file, enter the address and data length, and go to
[Extract KEY Data] from the File menu.

n KEY File Generator [Modified]

IW fddressSizel#)  Option{Q)  Help(H)

MNew( M)

i 22::8_;- KEY File Generator

Extract KEY DatalE).. I

End(:0) | File: |

W Address |Size | Type | Data I Title

00 01 02 03 04 05 06 07 0% 09 04 OB OC 0D OE OF

II_DDDFFFDF 1 HEX j ﬂ
ITDDDFFFEF 1 HEX j

ITDDDFFFFF 1 HEX j

T

IT HEX j

IT HEX j

IT HEX j

- |

IT HEX j

IT HEX j -

1 5 =
|
= I7
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Select a file to extract the data to be the key. The file which can be extracted is S format or HEX
format or binary.

open 20|
Laok e | (3 KEY File S @ mE-

=] taned. 281

TEST24K.5

Desktop

L

iy D'ocuments

"

My Computer

File name: I j Open I
Files af bype: |Dbiect File[* "] =l Cancel |
P

The extraction procedures vary with the file type to be extracted. After the extraction is completed,
the extracted data will be displayed in the Data area.

S format, HEX format:
Data are to be extracted by the specified address from the file.
Binary:

In order to extract the data, the first address of the file is required to be entered in the column of the
window shown below.

. Extract kEY Data

Input Start Address[HE=]

k. Cancel

- I3

DTS INSIGHT CORPORATION




<Note>
The error message below will appear and data will not be extracted when any text other than

1.
hexadecimal is input as the first address in a binary file.
B ERROR
y fddress Thput Error.
ADDRESS: 00000YE
2. The error message below will appear and data will not be extracted when there is no data

assigned at the specified address in the object file.
<Example>
B ERROR |

Data not found.
FILE: D:#¥KEY File¥TEST24k 5
ADDRESS: 00007000

SIFE: 16
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3-6 Clear the Input Data

In order to clear the input data, select [New] from the File menu.

B KEY File Generator [Modified]

File(F) AddressSize(d) Option(D) Help(H)

Ml M)

i 2 KEY File Generator

Extract KEY DatalE}..

End(x) File: |

|ﬁ Address | 5ize | Type Data Title

00 01 02 03 04 05 06 07 08 0% 04 OB 0OC 0D 0E OF

Il_ OOOFFFDF [1 HEx v||7C ﬁn‘
IT DOOFFFEF |1 HEX j sC

IT OOOFFFFF |1 HEX j E1l

IT mEx vl

IT mEx 7l
[s] | fm=x o
IT HEX 7]
IT HEX 7
IT mEx 7l

10 HEX -
o] [ Jj dl =

The message as shown below will appear when the data are being modified.

Click Yes to save the modified data.

Click No to discard the modified data.
To cancel the operation, click Cancel.

Il Destroy this data x|

! 3 This data is modified.

Do wou wank ko save the changes?

o Cancel
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4 End KEY File Generator

Select [End] from the File menu to close the KEY File Generator.

AR KEY File Generator [Modified]
FilefF) ~AddressSize(d) Option(Q) Help(H)
Ml W)

File Openid)... .
i 5232(5))_._ KEY File Generator

Extract KEY DatalE)...

End(:)

Iﬁ Address | Size | Type Data Title
00 01 02 03 04 05 06 07 08 09 04 OB 0OC 0D 0E OF
Il_oooozoon 3 2sc1L |7||[user_name user il
ITuouuzazn 8 |asciz |=||0s/0a/00 dote
ITDDDDIQDD 5 HEX j;m 95 |65 [zz [1F user ID
IT HEX j
IT HEX j
[ | fmz
IT HEX 7]
IT HEX j
IT HEX j
[10] | [z ! =

gl ']

The message as shown below will appear when the data are being modified.
Click Yes to save the modified data.

Click No to discard the modified data.

To cancel the operation, click Cancel.

Il Destroy this data x|

! 3 This data is modified.

Do wou wank ko save the changes?

o Cancel
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5 Displaying the Version Information

The version information can be displayed to deliver suitable technical support.
Select [Version] from the Help menu.

n KEY File Generator

FilelE) AddressSize(fiy  OptionfZ) | Help{H)

vers

KEY File Generator

File: |
Iﬁ Address | Size | Type | Data | Title
00 01 02 03 04 05 046 07 08 0% 0A OB OC 0D OE OF
Il_ HEX j ﬂ
IT HEX j
IT HEX j
[+ EEE
IT HEX j
IT HEX j
IT HEX j
[ = o |
IT HEX j
IT HEX j -
4 3 =

The message as shown below will be displayed.
Click OK to close the message.

File Generator Yerzion ]

EEY File Generator Version 2. 2.0
@ Copyrightic) 2005

DTS INSIGHT CORFPORATION
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6 APPENDIX

6-1 Error Message List

Operation Error Message Description
File Open lllegal file loading. The file type of the selected file is
Select the appropriate file invalid.
File Save Duplicated Address Two or more data are assigned at the
YOOXXX same address.
Save the file after correction the | (oo indicates the line number.)
duplicated Address
No Address. There are data with no address
LineNo: xxxxx specified.
(xooxxxx indicates the line number.)
llegal HEX Data. There is a line with invalid HEX data.
LineNo: xxxaxx (oo indicates the line number.)
File Save Error. The file has not been saved
successfully.
Extract KEY Data Data not found. There are no data at the specified
FILE: Xxxxxx address in the loaded file.
ADDRESS: yyyyyy XxXxxxx: File location
SIZE: zzzzzz yyyyyy: Address

zzzz7zz: Data length

Address Input Error.
ADDRESS: XXXXXX

The address
hexadecimal.
(oo indicates the address input.)

input is not in
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6-2 Installation of AZ481 KEY File Generator

<Installation Procedure>
1. AZ481 KEY File Generator is provided in a CD.
Set the installation CD in the CD-ROM driver of your PC.

Start the program (setup.exe) in the SetUp folder.
Installation requires Administrator privileges.

=101 %]
Fle Edit view Favorites Tools  Help | n
ek ~ () - (T | I search | Folders | | 50 X ) |,
Address | setup RN

g (& 9

az451.CAB setup.exe ETUP.LST

Double click
Setup.exe

- Z4
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2. Change the directory to install the KEY File Generator.

#3 KEY File Generatar Setup

@ Welcome to the KEY File Generatar installation program.
L=F

Setup cannot ingtall system files or update shared files if they are in
uze. Before proceeding, we recommend that wou close any applications

vou may be running.

Exit Setup

Click the Install button after selecting a directory.
Click here to start installation.

% KEY File Generator Setup

licking the button below.

Cilick this button to install KEY File Generator software to the specified
destination directory.

Directory:
’VG:?'EF'ngram Files¥KEY File Generatar¥ < Chanee Directory

Exit Setup | \

\
Click here to change the directory if needed.

- ZO
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The window will be displayed to add the KEY File Generator to the Program menu.
Select a group to add the KEY File Generator, and click the Continue button.

,.g, EEY File Generator — Choose Program Group §|

Setup will add items to the eroup shown in the Program Group
box. fou can enter @ new eroup name or select one from the
Exizting Groups list,

Proeram Group:
DTS INSIGHT Tools

Exizting Gru:uups:

Kﬂcu&url@‘ Eﬁftwam, :
Whicrozafl Wb Fublshne:

Ciontinue | Cancel

After the file is copied successfully, the message as shown below will appear.
The installation procedure has been completed.
Confirm the KEY File Generator added in the Program menu of the Start menu.

KEY File Generatar Setup

K.EY File Generator Setup was completed successfully.
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